数码控科技猎奇Iphone动漫星座游戏电竞lolcosplay王者荣耀攻略allcnewsBLOGNEWSBLOGASKBLOGBLOGZSK全部技术问答问答技术问答it问答代码软件新闻开发博客电脑/网络手机/数码笔记本电脑互联网操作系统软件硬件编程开发360产品资源分享电脑知识文档中心IT全部全部分类 全部分类技术牛文全部分类教程最新 网页制作cms教程平面设计媒体动画操作系统网站运营网络安全服务器教程数据库工具网络安全软件教学vbscript正则表达式javascript批处理更多»编程更新教程更新游戏更新allitnewsJava 新闻网络医疗信息化安全创业站长电商科技访谈域名会议专栏创业动态融资创投创业学院 / 产品经理创业公司人物访谈营销 开发数据库服务器系统虚拟化云计算 嵌入式移动开发作业作业1常见软件all电脑网络手机数码生活游戏体育运动明星影音休闲爱好文化艺术社会民生教育科学医疗健康金融管理情感社交地区其他电脑互联网软件硬件编程开发360相关产品手机平板其他电子产品摄影器材360硬件通讯智能设备购物时尚生活常识美容塑身服装服饰出行旅游交通汽车购房置业家居装修美食烹饪单机电脑游戏网页游戏电视游戏桌游棋牌游戏手机游戏小游戏掌机游戏客户端游戏集体游戏其他游戏体育赛事篮球足球其他运动球类运动赛车健身运动运动用品影视娱乐人物音乐动漫摄影摄像收藏宠物幽默搞笑起名花鸟鱼虫茶艺彩票星座占卜书画美术舞蹈小说图书器乐声乐小品相声戏剧戏曲手工艺品历史话题时事政治就业职场军事国防节日风俗法律法规宗教礼仪礼节自然灾害360维权社会人物升学入学人文社科外语资格考试公务员留学出国家庭教育学习方法语文物理生物工程学农业数学化学健康知识心理健康孕育早教内科外科妇产科儿科皮肤科五官科男科整形中医药品传染科其他疾病医院两性肿瘤科创业投资企业管理财务税务银行股票金融理财基金债券保险贸易商务文书国民经济爱情婚姻家庭烦恼北京上海重庆天津黑龙江吉林辽宁河北内蒙古山西陕西宁夏甘肃青海新疆西藏四川贵州云南河南湖北湖南山东江苏浙江安徽江西福建广东广西海南香港澳门台湾海外地区

Cisco路由器配置PPPoE+NAT

日期:2013/11/24 3:19:00 来源:本网整理
电信最近力推的ADSL是一种性能价格比较好的Internet接入方式,适用于只需访问Internet,不需要对外提供服务(如 WWW, Mail等)的场合。
  ADSL最常见的应用方式是用一台安装了PPPoE客户端软件的PC来拔号作代理服务器,让多台主机同时访问Internet。有的时候该PC的任务也可以用路由器来完成,最低档的2514路由器就能胜任,只要路由器有两个以太端网口即可。当然,还需要有适当的IOS软件,同时支持PPPoE Client和NAT两个特性、需求最低的IOS是“REMOTE access SERVER”特性集。以2621为例,运行该IOS只需32M内存、8M Flash,文件名为:c2600-c-mz.122-4.T1.bin ,这就是下面配置的运行环境。
  
  实际运行的配置:
  
  version 12.2
  
  service timestamps debug uptime
  
  service timestamps log uptime
  
  no service passWord-encryption
  
  !
  
  hostname 2621
  
  !
  
  enable secret 5 $1$LJV3$jqSDKFMSZiQBAjlnN/
  
  !
  
  ip subnet-zero
  
  ip name-server 202.xxx.xxx.xxx
  
  !
  
  vpdn enable
  
  !
  
  vpdn-group PPPoE
  
  request-dialin
  
  PRotocol pppoe
  
  !
  
  interface FastEthernet0/0
  
  ip address 10.1.1.1 255.255.255.0
  
  ip nat inside
  
  duplex auto
  
  speed auto
  
  !
  
  interface FastEthernet0/1
  
  no ip address
  
  speed 10
  
  half-duplex
  
  pppoe enable
  
  pppoe-client dial-pool-number 1
  
  !
  
  interface Dialer1
  
  mtu 1492
  
  ip address negotiated
  
  ip nat outside
  
  encapsulation ppp
  
  no ip mroute-cache
  
  dialer pool 1
  
  dialer-group 1
  
  no cdp enable
  
  ppp authentication pap callin
  
  ppp pap sent-username abc123@163 password 7 **********
  
  !
  
  ip nat inside source list 1 interface Dialer1 overload
  
  ip classless
  
  ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
  
  no ip http server
  
  ip pim bidir-enable
  
  !
  
  access-list 1 permit any
  
  dialer-list 1 protocol ip permit
  
  !
  
  line con 0
  
  line aux 0
  
  line vty 0 4
  
  password *****
  
  login
  
  !
  
  end
  
  在下行速度为2M的ADSL线路上,F0/0上接只一台PC,用蚂蚁下载测试时,峰值速度竟超过300K,不知道是不是蚂蚁有点夸大了。:-) 值得注重的
  是有的地区需要用chap认证方式,这时相应的指令为:
  
  ppp authentication chap callin
  
  ppp chap hostname abc123@163
  
  ppp chap password **********

  • 本文相关:
  • 基于广域网的三种信息交换模型分析
  • Cisco教育科研宽带IP网络建设案例
  • 思科应用控制引擎(ACE)模块概览
  • 感受统一通信:思科员工的一天
  • MPLS-OSPF Sham-Link
  • AAA SSH at pix 7.0
  • Tunnel-less VPN (Group Encrypted Transport)
  • GET VPN with a single Key Server
  • 镜像端口建立方法
  • Catalyst 6500/6000系列交换机的故障排除
  • 免责声明 - 关于我们 - 联系我们 - 广告联系 - 友情链接 - 帮助中心 - 频道导航
    Copyright © 2017 www.zgxue.com All Rights Reserved