yum包安装遇到Python版本问题该如何解

来源:互联网  责任编辑:小易  时间:2017/5/26 22:58:03
本网有用户碰到这样的问题:yum包安装遇到Python版本问题该如何解,具体问题如下:

yum?Python

本网根据需求用户需求,为用户寻得以下其他网友提供的解决方法,方法仅供参考,具体如下:

=================1楼=====================

你这个好奇葩

CentOS5最小安装也是带着python 2.4 和yum的呀。

你命令行打个# which python看看, python 装在哪里了?

要是没装只能去下个源码了。
https://www.python.org/ftp/python/2.4/Python-2.4.tar.bz2

# tar -xjvf Python-2.4.tar.bz2
# cd Python-2.4
# ./configure
# make && make  install

=================2楼=====================

你是升级yum的版本的?
我遇到过其他依赖Python的软件安装时的这类问题
先去安装镜像里找好当前Python的rpm包,然后用rpm -e 加 --nodeps参数卸载Python
然后再rpm安装一次Python就好了。。。。
不知道能不能解决你的问题 

如果您还有更好的解决方法,请在最下面评论中留下您的解决方法


  • 本文相关:
  • 站长必读,如何真正写好一篇原创文章
  • 互联网之路细嗅蔷薇 资深站长分享掘金之道
  • 企业站的站长的工作重心究竟有哪些
  • 浅析:行业门户网站的一些盈利模式
  • 3000IP的企业网站每天订单不到30个的苦恼
  • 网站想内外兼修?先学习提高网站可用性的6大原则
  • 浅谈网页设计中的简约之美
  • 网页改版实战:日本设计师如何彻底优化旅游网站?
  • 网页改版实战!日本设计师如何彻底优化招聘网站?
  • 2015年值得关注的21个网页设计趋势
  • 免责声明 - 关于我们 - 联系我们 - 广告联系 - 友情链接 - 帮助中心 - 频道导航
    Copyright © 2015 www.zgxue.com All Rights Reserved