数码控科技猎奇Iphone动漫星座游戏电竞lolcosplay王者荣耀攻略allcnewsBLOGNEWSBLOGASKBLOGBLOGZSK全部技术问答问答技术问答it问答代码软件新闻开发博客电脑/网络手机/数码笔记本电脑互联网操作系统软件硬件编程开发360产品资源分享电脑知识文档中心IT全部全部分类全部分类技术牛文全部分类教程最新网页制作cms教程平面设计媒体动画操作系统网站运营网络安全服务器教程数据库工具网络安全软件教学vbscript正则表达式javascript批处理更多»编程更新教程更新游戏更新allitnewsJava新闻网络医疗信息化安全创业站长电商科技访谈域名会议专栏创业动态融资创投创业学院 / 产品经理创业公司人物访谈营销开发数据库服务器系统虚拟化云计算嵌入式移动开发作业作业1常见软件all电脑网络手机数码生活游戏体育运动明星影音休闲爱好文化艺术社会民生教育科学医疗健康金融管理情感社交地区其他电脑互联网软件硬件编程开发360相关产品手机平板其他电子产品摄影器材360硬件通讯智能设备购物时尚生活常识美容塑身服装服饰出行旅游交通汽车购房置业家居装修美食烹饪单机电脑游戏网页游戏电视游戏桌游棋牌游戏手机游戏小游戏掌机游戏客户端游戏集体游戏其他游戏体育赛事篮球足球其他运动球类运动赛车健身运动运动用品影视娱乐人物音乐动漫摄影摄像收藏宠物幽默搞笑起名花鸟鱼虫茶艺彩票星座占卜书画美术舞蹈小说图书器乐声乐小品相声戏剧戏曲手工艺品历史话题时事政治就业职场军事国防节日风俗法律法规宗教礼仪礼节自然灾害360维权社会人物升学入学人文社科外语资格考试公务员留学出国家庭教育学习方法语文物理生物工程学农业数学化学健康知识心理健康孕育早教内科外科妇产科儿科皮肤科五官科男科整形中医药品传染科其他疾病医院两性肿瘤科创业投资企业管理财务税务银行股票金融理财基金债券保险贸易商务文书国民经济爱情婚姻家庭烦恼北京上海重庆天津黑龙江吉林辽宁河北内蒙古山西陕西宁夏甘肃青海新疆西藏四川贵州云南河南湖北湖南山东江苏浙江安徽江西福建广东广西海南香港澳门台湾海外地区

易语言用正则采集百度知道的代码

来源:脚本之家  责任编辑:小易  

常量数据表

.版本 2
.常量 标题, "<文本长度: 25>", , "ti"((\r\n|\s*).*>.*)</a>
.常量 标题需替换的内容, "<文本长度: 17>", , target="_blank">
.常量 提问时间, "<文本长度: 36>", , "mr-8">(\d{4,}-\d{1,}-\d{1,})</span>
.常量 帖子链接与回答数量, "<文本长度: 93>", , <a href="(http:.*)" rel="external nofollow" target="_blank" class="f-light nod" data-   log="pos:ans,si:\d{1,}">(.*)</a>
.常量 回答内容, "<文本长度: 40>", , <i class="i-answer-text">答:</i>.*</dd>
.常量 回答内容需替换的, "<文本长度: 25>", , <i class="i-answer-text">
.常量 回答者, "<文本长度: 27>", , 回答者:<a href=.*>(.*)</a>

百度知道采集器

此功能需要加载精易模块5.6

.版本 2
.支持库 iext
.程序集 窗口程序集1
.程序集变量 搜索的内容, 文本型
.程序集变量 网页源码, 文本型
.程序集变量 页码变量, 整数型
.程序集变量 网址, 文本型
.子程序 _按钮_搜索_被单击
.局部变量 i, 整数型
.局部变量 i2, 整数型
.局部变量 i3, 整数型
.如果 (编辑框_搜索内容.内容 ≠ “”)
  超级列表框1.全部删除 ()
  .判断循环首 (页码变量 < 21)
    搜索内容 ()
    正则 ()
    页码变量 = 页码变量 + 10
  .判断循环尾 ()
  .计次循环首 (超级列表框1.取表项数 (), i2)
    超级列表框1.置标题 (i2 - 1, 0, 到文本 (i2))
  .计次循环尾 ()
  页码变量 = 0
.否则
  信息框 (“请先输入要搜索的问题”, #信息图标, “提示”)
  编辑框_搜索内容.获取焦点 ()
.如果结束
.子程序 搜索内容
按钮_搜索.标题 = “正在搜索中...”
搜索的内容 = 编辑框_搜索内容.内容
网址 = “http://zhidao.baidu.com/search?word=” + 编码_URL编码 (搜索的内容) + “&ie=gbk&site=-1&sites=0&date=0&pn=” + 到文本 (页码变量)
网页源码 = 网页_取网页源码 (网址)
.子程序 正则
.局部变量 正则标题与序号, 正则表达式类
.局部变量 局_计次, 整数型
.局部变量 表项索引, 整数型
.局部变量 正则链接与回答数, 正则表达式类
.局部变量 正则回答, 正则表达式类
.局部变量 正则回答时间, 正则表达式类
.局部变量 正则回答者, 正则表达式类
正则标题与序号.创建 (#标题, 网页源码)
正则链接与回答数.创建 (#帖子链接与回答数量, 网页源码)
正则回答.创建 (#回答内容, 网页源码)
正则回答时间.创建 (#提问时间, 网页源码)
正则回答者.创建 (#回答者, 网页源码)
.计次循环首 (正则标题与序号.取匹配数量 (), 局_计次)
  表项索引 = 超级列表框1.插入表项 (, , , , , )
  超级列表框1.置标题 (表项索引, 1, 文本_替换 (正则标题与序号.取子匹配文本 (局_计次, 1), , , , “>”, “”, “<em>”, “”, “</em>”, “</a>”, “<em”, “”, “</em”, “”)) ' 标题
  .如果 (寻找文本 (正则链接与回答数.取子匹配文本 (局_计次, 1), “html”, , 假) = -1)
    超级列表框1.置标题 (表项索引, 4, “”)
  .否则
    超级列表框1.置标题 (表项索引, 4, 正则链接与回答数.取子匹配文本 (局_计次, 1)) ' 链接
  .如果结束
  超级列表框1.置标题 (表项索引, 2, 文本_替换 (正则回答.取匹配文本 (局_计次, ), , , , #回答内容需替换的, “”, “</i>”, “”, “<em>”, “”, “</em>”, “”, “</dd>”, “”)) ' 回答
  超级列表框1.置标题 (表项索引, 3, 正则链接与回答数.取子匹配文本 (局_计次, 2)) ' 回答的数量
  超级列表框1.置标题 (表项索引, 5, 正则回答时间.取子匹配文本 (局_计次, 1)) ' 回答的时间
.计次循环尾 ()
按钮_搜索.标题 = “搜索答案”
.子程序 _超级列表框1_被双击, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
_预览此内容_被选择 ()
.子程序 _预览此内容_被选择
.如果真 (信息框 (_启动窗口.超级列表框1.取标题 (_启动窗口.超级列表框1.现行选中项, 2) + #换行符 + “-------------------------------” + #换行符 + “是否浏览更多回答?”, #是否钮 + #询问图标, 超级列表框1.取标题 (超级列表框1.现行选中项, 1)) = #是钮)
  _打开此链接_被选择 ()
.如果真结束
.子程序 _超级列表框1_鼠标右键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
.如果真 (超级列表框1.取表项数 () ≠ 0)
  弹出菜单 (菜单, , )
.如果真结束
.子程序 _打开此链接_被选择
网页_打开指定网址 (超级列表框1.取标题 (超级列表框1.现行选中项, 4))
.子程序 _复制回答_被选择
.如果真 (置剪辑板文本 (超级列表框1.取标题 (超级列表框1.现行选中项, 2)) = 真)
  信息框 (“成功复制!”, #信息图标, “复制成功”)
.如果真结束
.子程序 __启动窗口_创建完毕
页码变量 = 0
编辑框_搜索内容.获取焦点 ()
.子程序 _复制此链接_被选择
.如果真 (置剪辑板文本 (超级列表框1.取标题 (超级列表框1.现行选中项, 4)) = 真)
  信息框 (“成功复制!”, #信息图标, “复制成功”)
.如果真结束
.子程序 _编辑框_搜索内容_内容被改变
.如果真 (编辑框_搜索内容.内容 = “”)
  页码变量 = 0
.如果真结束
.子程序 _编辑框_搜索内容_按下某键, 逻辑型
.参数 键代码, 整数型
.参数 功能键状态, 整数型
.如果真 (键代码 = #回车键)
  _按钮_搜索_被单击 ()
.如果真结束
.子程序 _获取更多回答_被选择
网页_打开指定网址 (“http://zhidao.baidu.com/search?word=” + 编码_URL编码 (搜索的内容) + “&ie=gbk&site=-1&sites=0&date=0&pn=0”)
.子程序 _按钮_关闭_被单击
结束 ()
.子程序 _按钮_获取更多回答_被单击
_获取更多回答_被选择 ()

运行结果:

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对脚本之家的支持。如果你想了解更多相关内容请查看下面相关链接

您可能感兴趣的文章:


  • 本文相关:
  • 易语言制作酷狗付费音乐解析下载工具
  • 易语言制作汽车油耗计算器的代码
  • 易语言破解wps的vip模版下载地址
  • 易语言修改软件版权信息的工具
  • 易语言qq群发支持图片文字数据一起发送的工具
  • 易语言统计代码行数与api的工具
  • 易语言自动识别快递公司查件免验证码的代码
  • 易语言制作qq前台全自动无限加好友的代码
  • 易语言调用百度的真相问答制作真相问答机的代码
  • 易语言使用超文本显示新浪天气预报的代码
  • 易语言使用动画框做消除游戏的代码
  • 易语言制作网截抓包工具的代码
  • 易语言实现无需加好友强制查看qq资料卡片的方法
  • 易语言制作二维码生成器
  • 易语言制作方言版语音合成工具
  • 易语言设置时钟周期与周期事件实现运行或停止时钟的方法
  • 易语言设置编辑框中文字对齐方式的方法
  • 易语言取整命令使用讲解
  • 易语言设置滑块条刻度类型的方法
  • 易语言测试与指定主机是否能够正常通讯
  • 易语言在画板中写出指定文本当画板中已满会自动滚屏
  • 易语言发音比较命令使用讲解
  • 易语言获取汉字发音数目和拼音并取声母和韵母
  • 易语言免费领取ofo小黄车三个月骑乘卡的代码
  • 易语言整除命令使用讲解
  • 免责声明 - 关于我们 - 联系我们 - 广告联系 - 友情链接 - 帮助中心 - 频道导航
    Copyright © 2017 www.zgxue.com All Rights Reserved