多版本python的pip 升级后, pip2 pip3 与python版本失配解决方法

来源:脚本之家  责任编辑:小易  

mint19.2   本来pip 和 pip2 对应 python2.7   pip3对应python3.6  

用源码安装了python3.7之后. 这样

版本也没问题.

但是,  用pip3.7 安装包的时候 提示 pip需要升级,  但是一旦升级, 就不对了

pip  pip2 pip3 都指向了pip3.7

这导致一系列问题. 包pgadmin4 启动后报 csrf 错误 , 甚至进而导致docker-compose模式下postgres服务下线!

而且,无法用重装python-pip, python3-pip 来解决

  • sudo apt remove python-pip
  • sudo apt install python-pip

解决方案:

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
sudo python3 get-pip.py
sudo python2 get-pip.py

注意先恢复3.6的, 再恢复2.7的

 

搞定

以上就是关于多版本python的pip 升级后, pip2 pip3 与python版本失配的实例解决方法,感谢大家对脚本之家的支持。


  • 本文相关:
  • python 条件判断的缩写方法
  • 对python tkinter窗口弹出置顶的方法详解
  • python 2.x如何设置命令执行的超时时间实例
  • python实现将汉字转换成汉语拼音的库
  • python实现随机梯度下降法
  • pymysql模块的使用(增删改查)详解
  • django 外键model的互相读取方法
  • django组合搜索实现过程详解(附代码)
  • 深入理解javascript中的this关键字
  • 详解多线程django程序耗尽数据库连接的问题
  • 免责声明 - 关于我们 - 联系我们 - 广告联系 - 友情链接 - 帮助中心 - 频道导航
    Copyright © 2017 www.zgxue.com All Rights Reserved