超详细讲解Linux DHCP服务_Linux

来源:脚本之家  责任编辑:小易  
目录
一、DHCP服务(动态主机配置协议)1.背景2.概述3.优点4.DHCP报文类型5.DHCP 的分配方式二、安装 DHCP 服务器1.DHCP 服务软件2.主配置文件三、配置步骤1.使用 DHCP 动态的给 PC 机分配 IP 地址① eNSP②虚拟机③验证④进入命令行“ipconfig”测试

一、DHCP服务(动态主机配置协议)

1.背景

1.手动设置工作量大且容易冲突

2.用DHCP可以减少工作量和避免地址冲突

2.概述

作用:为局域网内的电脑分配IP地址 架构 C/S;客户端/服务器模式 实现方式:

1.为相同网段的电脑分配IP地址—DHCP

2.跨网段为另一网段的电脑分配IP地址—DHCP中继

DHCP使用UDP协议,67号是客户机使用的,68号是服务器端的端口号

3.优点

1.减少管理员的工作量

2.避免输入错误的可能

3.避免IP地址冲突

4.当更改IP地址段时,不需要重新配置每个用户的IP地址

5.提高了IP地址的利用率

6.方便客户端的配置

4.DHCP报文类型

以找工作为例:

DHCP Discover——客户端用来寻找DHCP服务器的报文
我向公司投简历来找工作

DHCP Offer——DHCP服务器用来响应DHCP Discover报文的报文。该报文携带了各种配置信息,例如IP地址,DNS等
公司收到我的求职简历后给我发了一份offer

DHCP Request——客户端请求配置确认,或者续借租期
我收到offer之后跟公司确认

DHCP ACK——服务器对Request报文的确认响应
公司说我ok没问题,可以过来上班 ,我找到工作了

5.DHCP 的分配方式

①自动分配:
当DHCP客户机第一次成功地从DHCP服务器获取到一个IP地址后,就永久的使用这个IP地址
②手动分配:
由DHCP服务器管理员专门指定IP地址
③动态分配:
当DHCP客户机第一次从DHCP服务器获得IP地址后,并非永久的使用该地址,而是在每次使用完后,DHCP客户机就会释放这个IP地址,供其他客户机使用

二、安装 DHCP 服务器

1.DHCP 服务软件

CentOS光盘中的 dhcp-4.2.5-47.el7.centos.x86_64.rpm 一般都有,没有的话 RPM 去安装一下

mark

DHCP 软件包的主要文件

主配置文件:/etc/dhcpd.conf

执行程序:/usr/sbin/dhcpd、usr/sbin/dhcrelay

2.主配置文件

dhcpd.conf 的内容构成
ddns-update-style  interim;     #全局配置参数
......
subnet  192.168.0.0  netmask  255.255.255.0 {       #subnet以上的都是全局配置参数;网段声明(网段、子网掩码、默认网关地址)
   option routers 192.168.0.1;       #配置选项
   ......
   default-lease-time 21600;   #配置参数
   host ns {
      ......    
      fixed-address 207.175.42.254;    #主机声明(固定一个IP给主机用的)
   }
}        
Subnet网段声明,作用于整个子网段

range参数:设置用于分配的IP地址池

option subnet-mask参数:设置客户机的子网掩码

option routers参数:设置客户机的默认网关地址

三、配置步骤

1.使用 DHCP 动态的给 PC 机分配 IP 地址

① eNSP

实验拓扑图如下

注:配置完“Cloud”之后才能用串口线连接

mark

配置Cloud

mark

SW1基本配置
<Huawei>undo terminal monitor 
<Huawei>system-view 
[L2-SW1]user-interface console 0
[L2-SW1-ui-console0]idle-timeout 0 0
[L2-SW1-ui-console0]quit 
[L2-SW1]vlan batch 10 20 100
[L2-SW1]interface Ethernet 0/0/1	
[L2-SW1-Ethernet0/0/1]port link-type access 	
[L2-SW1-Ethernet0/0/1]port default vlan 10
[L2-SW1-Ethernet0/0/1]quit
[L2-SW1]interface Ethernet 0/0/2	
[L2-SW1-Ethernet0/0/2]port link-type access 	
[L2-SW1-Ethernet0/0/2]port default vlan 20
[L2-SW1-Ethernet0/0/2]quit
[L2-SW1]interface Ethernet 0/0/3	
[L2-SW1-Ethernet0/0/3]port link-type access 	
[L2-SW1-Ethernet0/0/3]port default vlan 100
[L2-SW1-Ethernet0/0/3]quit
[L2-SW1]interface Ethernet 0/0/4	
[L2-SW1-Ethernet0/0/4]port link-type access 	
[L2-SW1-Ethernet0/0/4]port default vlan 100
[L2-SW1-Ethernet0/0/4]quit
[L2-SW1]interface GigabitEthernet0/0/1
[L2-SW1-GigabitEthernet0/0/1]port link-type trunk
[L2-SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20 100
[L2-SW1-GigabitEthernet0/0/1]quit
SW2基本配置
<Huawei>undo terminal monitor 
<Huawei>system-view 
[Huawei]sysname L3-SW2
[L3-SW2]user-interface console 0
[L3-SW2-ui-console0]idle-timeout 0 0
[L3-SW2-ui-console0]quit
[L3-SW2]vlan batch 10 20 100
[L3-SW2]interface GigabitEthernet0/0/1
[L3-SW2-GigabitEthernet0/0/1]port link-type trunk
[L3-SW2-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20 100
[L3-SW2-GigabitEthernet0/0/1]quit
[L3-SW2]interface Vlanif 10	
[L3-SW2-Vlanif10]ip address 192.168.10.1 255.255.255.0	
[SW2-Vlanif20]un sh
[L3-SW2]interface Vlanif 20	
[L3-SW2-Vlanif20]ip address 192.168.20.1 255.255.255.0	
[SW2-Vlanif20]un sh
[L3-SW2]interface Vlanif 100
[L3-SW2-Vlanif100]ip address 192.168.100.1 255.255.255.0	
[SW2-Vlanif20]un sh
[SW2-Vlanif100]int g0/0/1
[SW2-GigabitEthernet0/0/1]port link-type trunk 
[SW2-GigabitEthernet0/0/1]port trunk allow-pass vlan all 
配置DHCP中继(三层交换机)
[L3-SW2]dhcp enable               ##开启DHCP功能
[L3-SW2]interface Vlanif 10	      ##配置虚接口ip,选择dhcp中继模式,请求指向dhcp服务器ip
[L3-SW2-Vlanif10]dhcp select relay 	
[L3-SW2-Vlanif10]dhcp relay server-ip 192.168.100.100	
[L3-SW2-Vlanif10]quit 	
[L3-SW2]interface Vlanif 20	
[L3-SW2-Vlanif20]dhcp select relay 
[L3-SW2-Vlanif20]dhcp relay server-ip 192.168.100.100	
[L3-SW2-Vlanif20]quit 	
[L3-SW2]interface Vlanif 100	
[L3-SW2-Vlanif100]dhcp select relay 
[L3-SW2-Vlanif100]dhcp relay server-ip 192.168.100.100
[L3-SW2-Vlanif100]quit 

②虚拟机

选择虚拟机网络类型

mark

配置网卡IP

mark

安装dhcp软件包,并查看和找到配置文件
[root@xjj ~]# yum -y install dhcp
已加载插件:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
软件包 12:dhcp-4.2.5-58.el7.centos.x86_64 已安装并且是最新版本
无须任何处理

[root@xjj ~]# cd /etc/dhcp/        ##dhcp的配置文件是/etc/dhcp/dhcpd.conf
[root@xjj dhcp]# ls
dhclient.d  dhclient-exit-hooks.d  dhcpd6.conf  dhcpd.conf  scripts
[root@xjj dhcp]# less dhcpd.conf        ##查看一下内容

[root@xjj ~]# cd /usr/share/doc/dhcp-4.2.5/        到该目录下去寻找dhcp配置模板
[root@xjj dhcp-4.2.5]# ls        ##“dhcpd.conf.example”
dhcpd6.conf.example  dhcpd.conf.example  ldap
[root@xjj dhcp-4.2.5]# cp dhcpd.conf.example /etc/dhcp/dhcpd.conf        ##将模板覆盖到/etc/dhcp/dhcpd.conf中
cp:是否覆盖"/etc/dhcp/dhcpd.conf"? y

[root@xjj ~]# cd /etc/dhcp/        ##回到/etc/dhcp目录下
[root@xjj dhcp]# ls
dhclient.d  dhclient-exit-hooks.d  dhcpd6.conf  dhcpd.conf  scripts
[root@xjj dhcp]# less dhcpd.conf        ##查看配置文件并进行下一步编辑

编辑dhcp配置文件

[root@xjj dhcp]# vim dhcpd.conf

mark

关闭防火墙,重启网卡,再去“ping”进行验证网络
[root@xjj dhcp]# systemctl stop firewalld
se[root@jj dhcp]# setenforce 0
##记得重启一下网卡!
[root@xjj dhcp]# systemctl restart dhcpd


[root@xjj dhcp]# ping 192.168.100.1
...略
[root@xjj dhcp]# ping 192.168.10.1
...略
[root@xjj dhcp]# ping 192.168.20.1
...略

③验证

到eNSP中验证一下 首先开启两台PC的DHCP来自动获取一下IP地址

mark

mark

④进入命令行“ipconfig”测试

pc1

mark

pc2

mark

pc1和pc2成功!!!

以上就是超详细讲解Linux DHCP服务的详细内容,更多关于Linux DHCP服务的资料请关注真格学网其它相关文章!

您可能感兴趣的文章:Linux实现DHCP服务器的搭建linux启动dhcp服务器步骤linux下dhcp服务配置教程linux下的dhcp服务的完全配置(图文详解)

  • 本文相关:
  • ubuntu下sublime text无法输入中文最简单的解决方案
  • linux下查看系统进程占用的句柄数方法
  • linux下的多线程编程实例解析
  • 查看远程 linux 系统中某个端口是否开启的三种方法
  • win7安装和配置apache2.4服务器的详细方法
  • linux查找大文件指定内容的实现方法
  • 详解ssh如何配置key免密码登录
  • apache配置多个站点的方法
  • 让apache显示目录列表的配置方法
  • linux vps主机上备份网站和数据库的方法
  • LINUX RHEL6 开启DHCP服务的详细步骤!
  • LINUX下DHCP服务无法启动并且无错误提示
  • Linux下如何安装DHCP服务和使用
  • 怎么查看LINUX的DHCP服务是否开启
  • 我要写一篇基于LINUX下DHCP分配不同网段IP地址
  • linux如何配置dhcp服务器
  • 请问linux下dhcp多作用域怎样配置?????
  • Red Hat Enterprise Linux 5 DHCP服务的配置
  • 一家公司有300台电脑用Linux中的DHCP服务器怎么配置?求高...
  • 如何在虚拟机Linux下配置DHCP服务器
  • 怎么安装DHCP到linux里
  • 在Linux中配置NFS和DHCP服务器?
  • linux Suse 中BOOTPROTO=‘dhcp’ dhcp为什么删不掉?
  • linuxdhcp
  • 网站首页网页制作脚本下载服务器操作系统网站运营平面设计媒体动画电脑基础硬件教程网络安全星外虚拟主机华众虚拟主机linuxwin服务器ftp服务器dns服务器tomcat nginxzabbix云和虚拟化服务器其它首页服务器linuxlinux实现dhcp服务器的搭建linux启动dhcp服务器步骤linux下dhcp服务配置教程linux下的dhcp服务的完全配置(图文详解)ubuntu下sublime text无法输入中文最简单的解决方案linux下查看系统进程占用的句柄数方法linux下的多线程编程实例解析查看远程 linux 系统中某个端口是否开启的三种方法win7安装和配置apache2.4服务器的详细方法linux查找大文件指定内容的实现方法详解ssh如何配置key免密码登录apache配置多个站点的方法让apache显示目录列表的配置方法linux vps主机上备份网站和数据库的方法apache开启.htaccess及.htaccessservice temporarily unavailabllinux下实现免密码登录(超详细)apache rewrite url重定向功能的linux下用cron定时执行任务的方法apache性能测试工具ab使用详解阿里云服务器ping不通解决办法(centos 6.4安装配置lamp服务器(alinux nohup实现后台运行程序及查centos+nginx+php+mysql详细配置centos7上mesos和marathon的安装和配置ubuntu 14.04设置开机启动脚本的方法linux sftp命令用法总结centos6.5系统简单安装与配置nginx服务器linux中的who命令实例介绍rsync中文手册之使用rsync实现网站镜像和linux查看ip的实例方法linux安装redis和mysql的实例讲解详解linux手动释放缓存的方法centos7安装mysql并jdbc测试实例详解
    免责声明 - 关于我们 - 联系我们 - 广告联系 - 友情链接 - 帮助中心 - 频道导航
    Copyright © 2017 www.zgxue.com All Rights Reserved